Carte geologiche su Android

Ciao a tutti!

Sono riuscito a scaricare i TIFF che mi interessavano della carta geologica Toscana per poi poterli utilizzare su Oruxmaps Android
Il problema è che Oruxmapsdesktop (necessario per convertire i tif) da come errore che "Coordinate System not supported"
Ho provato con un altro programma Avenza Map, ma anche lui mi dice che non ci sono coordinate dentro il file.
Inutile dire che il TIF originale risulta georeferenziato, ha anche il relativo file .tfw

Avete qualche altra idea?

Grazie mille
 
Grazie Sustuso,
nonostante abbia seguito il tutorial per unire il file .tfw al tif sembra che qualcosa non abbia funzionato correttamente:

Driver: GTiff/GeoTIFF
Files: 276040.tif
Size is 8128, 6809
Coordinate System is:
LOCAL_CS["unnamed",
UNIT["unknown",1]]

Origin = (1707771.265654539922252,4853023.783147510141134)
Pixel Size = (0.846988999999970,-0.846988999999970)
Metadata:
AREA_OR_POINT=Point
TIFFTAG_RESOLUTIONUNIT=1 (unitless)
TIFFTAG_SOFTWARE=Arc/Info
TIFFTAG_XRESOLUTION=1.1799999
TIFFTAG_YRESOLUTION=1.1799999
Image Structure Metadata:
INTERLEAVE=BAND
Corner Coordinates:
Upper Left ( 1707771.266, 4853023.783)
Lower Left ( 1707771.266, 4847256.635)
Upper Right ( 1714655.592, 4853023.783)
Lower Right ( 1714655.592, 4847256.635)
Center ( 1711213.429, 4850140.209)
Band 1 Block=8128x2 Type=Byte, ColorInterp=Palette
Color Table (RGB with 256 entries)
0: 0,0,0,255
1: 0,0,7,255
2: 0,7,3,255
3: 7,0,0,255
4: 7,0,7,255
5: 7,7,0,255
6: 7,11,3,255
7: 21,7,1,255
8: 5,8,17,255
9: 25,19,16,255
10: 24,31,24,255
11: 41,39,17,255
12: 32,31,37,255
13: 8,16,74,255
14: 32,46,42,255
15: 38,53,56,255
16: 62,26,17,255
17: 61,46,28,255
18: 64,42,46,255
19: 73,48,40,255
20: 57,64,31,255
21: 73,60,36,255
22: 56,48,56,255

Continua poi fino all numero 255

Scusa ma non so proprio che pesci prendere! grazie ancora
 
Il problema è che Oruxmapsdesktop (necessario per convertire i tif) da come errore che "Coordinate System not supported"
Coordinate System is:
LOCAL_CS["unnamed",
UNIT["unknown",1]]

Corner Coordinates:
Upper Left ( 1707771.266, 4853023.783)
Lower Left ( 1707771.266, 4847256.635)
Upper Right ( 1714655.592, 4853023.783)
Lower Right ( 1714655.592, 4847256.635)
Center ( 1711213.429, 4850140.209)
La mappa è calibrata con coordinate Gauss Boaga Roma40, che Oruxmapsdesktop evidentemente non riconosce.

Devi ricalibrare/riproiettare la mappa con un qualsiasi programma cartografico utilizzando Lat/Long WGS84 o UTM WGS84.

francesco
 
Ultima modifica:
Ho provato impostando queste opzioni in Qgis, ultima versione

190278


Ho poi esportato il tutto in tif, ma quando la apro in Oruxmapsdesktop mi avvisa che :

Error reading Geotiff file; Datum/Projection unknown.

Se clicco su ok, mi avvisa che non riconsce appunto il Datum e di inserirlo manualmente. Stessa cosa per la proiezione. Ho provato a metterle manualmente: come datum WGS1984 e Proiezione UTM fuso 32 ma mi da errore: P1 Error parsing coordinate, ignored e P2 Error parsing coordinate, ignored poi dice che Oruxmapsdektop ha bisogno di almeno due coordinate e non va avanti

Avevo provato già ieri ad impostare la proiezione segnalata dal sito della regione toscana, come visto da te:

Il dataset è rilasciato in formato raster tiff georeferenziato tramite world-file e nel sistema di
riferimento Gauss-Boaga Fuso Ovest (EPSG:3003)

ma avevo gli stessi problemi

Grazie mille


EDIT:

aggiungo che con gdalinfo sembrerebbe tutto ok questa volta:

Coordinate System is:
GEOGCS["WGS 84",
DATUM["WGS_1984",
SPHEROID["WGS 84",6378137,298.257223563,
AUTHORITY["EPSG","7030"]],
AUTHORITY["EPSG","6326"]],
PRIMEM["Greenwich",0],
UNIT["degree",0.0174532925199433],
AUTHORITY["EPSG","4326"]]
Origin = (1706719.850886899977922,4853167.538355532102287)
Pixel Size = (0.846965992864974,-0.847042314456545)
Metadata:
AREA_OR_POINT=Area
Image Structure Metadata:
INTERLEAVE=PIXEL
Corner Coordinates:
Upper Left ( 1706719.851, 4853167.538) (Invalid angle,Invalid angle)
Lower Left ( 1706719.851, 4847112.033) (Invalid angle,Invalid angle)
Upper Right ( 1715707.854, 4853167.538) (Invalid angle,Invalid angle)
Lower Right ( 1715707.854, 4847112.033) (Invalid angle,Invalid angle)
Center ( 1711213.852, 4850139.786) (Invalid angle,Invalid angle)
Band 1 Block=10612x1 Type=Byte, ColorInterp=Red
Mask Flags: PER_DATASET ALPHA
Band 2 Block=10612x1 Type=Byte, ColorInterp=Green
Mask Flags: PER_DATASET ALPHA
Band 3 Block=10612x1 Type=Byte, ColorInterp=Blue
Mask Flags: PER_DATASET ALPHA
Band 4 Block=10612x1 Type=Byte, ColorInterp=Alpha
 
Ultima modifica:
aggiungo che con gdalinfo sembrerebbe tutto ok questa volta:

Coordinate System is:
GEOGCS["WGS 84",
DATUM["WGS_1984",
SPHEROID["WGS 84",6378137,298.257223563,
AUTHORITY["EPSG","7030"]],
AUTHORITY["EPSG","6326"]],
PRIMEM["Greenwich",0],
UNIT["degree",0.0174532925199433],
AUTHORITY["EPSG","4326"]]
Origin = (1706719.850886899977922,4853167.538355532102287)
Pixel Size = (0.846965992864974,-0.847042314456545)
Metadata:
AREA_OR_POINT=Area
Image Structure Metadata:
INTERLEAVE=PIXEL
Corner Coordinates:
Upper Left ( 1706719.851, 4853167.538) (Invalid angle,Invalid angle)
Lower Left ( 1706719.851, 4847112.033) (Invalid angle,Invalid angle)
Upper Right ( 1715707.854, 4853167.538) (Invalid angle,Invalid angle)
Lower Right ( 1715707.854, 4847112.033) (Invalid angle,Invalid angle)
Center ( 1711213.852, 4850139.786) (Invalid angle,Invalid angle)
Non è OK perchè anche se risultano coordinate Lat/Long Datum WGS84 i valori inseriti sono sempre coordinate metriche Gauss Boaga, come puoi vedere dalla nota vicino alle coordinate (Invalid angle,Invalid angle).

Carica il file in Qgis selezionando EPSG:3003, poi lo esporti in Layer->Salva con nome.... selezionando SR EPSG:32632 per il fuso 32 o EPSG:32633 per il fuso 33.




Volendo puoi anche mettere la spunta su "Crea VRT", cosi salvi anche un file di calibrazione in formato testo. Comunque il file .tif che viene salvato contiene già le informazioni di calibrazione.

<VRTDataset rasterXSize="8342" rasterYSize="6911">
<SRS>PROJCS["WGS 84 / UTM zone 32N",GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",0],PARAMETER["central_meridian",9],PARAMETER["scale_factor",0.9996],PARAMETER["false_easting",500000],PARAMETER["false_northing",0],UNIT["metre",1,AUTHORITY["EPSG","9001"]],AXIS["Easting",EAST],AXIS["Northing",NORTH],AUTHORITY["EPSG","32632"]]</SRS>
<GeoTransform>668095, 0.846994, 0, 4.82411e+06, 0, -0.846915</GeoTransform>

Purtroppo con un file di prova che ho scaricato dalla regione Toscana vedo che il tif prodotto da Qgis perde un pò di qualità rispetto all'originale.

francesco
 
Ultima modifica:
Prima di tutto, grazie mille per la disponibilità e la pazienza.

Ho fatto come hai detto ma OruxmapsDesktop mi da lo stesso errore.

Conosci qualche app per Android che possa usare direttamente il .tif ?

Questo il report di qdalinfo:

Driver: GTiff/GeoTIFF
Files: prova.tif
Size is 8126, 6808
Coordinate System is:
PROJCS["WGS 84 / UTM zone 32N",
GEOGCS["WGS 84",
DATUM["WGS_1984",
SPHEROID["WGS 84",6378137,298.257223563,
AUTHORITY["EPSG","7030"]],
AUTHORITY["EPSG","6326"]],
PRIMEM["Greenwich",0],
UNIT["degree",0.0174532925199433],
AUTHORITY["EPSG","4326"]],
PROJECTION["Transverse_Mercator"],
PARAMETER["latitude_of_origin",0],
PARAMETER["central_meridian",9],
PARAMETER["scale_factor",0.9996],
PARAMETER["false_easting",500000],
PARAMETER["false_northing",0],
UNIT["metre",1,
AUTHORITY["EPSG","9001"]],
AUTHORITY["EPSG","32632"]]
Origin = (707740.792499999981374,4853007.602599999867380)
Pixel Size = (0.847184285011076,-0.847101439482896)
Metadata:
AREA_OR_POINT=Area
Image Structure Metadata:
INTERLEAVE=PIXEL
Corner Coordinates:
Upper Left ( 707740.792, 4853007.603) ( 11d34'56.87"E, 43d48' 3.45"N)
Lower Left ( 707740.792, 4847240.536) ( 11d34'48.84"E, 43d44'56.70"N)
Upper Right ( 714625.012, 4853007.603) ( 11d40' 4.63"E, 43d47'56.37"N)
Lower Right ( 714625.012, 4847240.536) ( 11d39'56.33"E, 43d44'49.64"N)
Center ( 711182.902, 4850124.069) ( 11d37'26.67"E, 43d46'26.57"N)
Band 1 Block=8126x1 Type=Byte, ColorInterp=Red
Mask Flags: PER_DATASET ALPHA
Band 2 Block=8126x1 Type=Byte, ColorInterp=Green
Mask Flags: PER_DATASET ALPHA
Band 3 Block=8126x1 Type=Byte, ColorInterp=Blue
Mask Flags: PER_DATASET ALPHA
Band 4 Block=8126x1 Type=Byte, ColorInterp=Alpha

Grazie ancora!
 
Ho fatto come hai detto ma OruxmapsDesktop mi da lo stesso errore.

Conosci qualche app per Android che possa usare direttamente il .tif ?
Non riesco nemmeno io a convertire un file .tif, credo che occorra aggiungere qualche modulo extra a Java.

In attesa che qualcuno riporti come risolvere questo problema, ho comunque risolto utilizzando un file immagine .jpg.
Per l'occasione ho anche visto che si può caricare direttamente in Oruxmapsdesktop la mappa con il file di calibrazione Gauss Boaga con un piccolo trucco, senza dover passare da Qgis.

Innanzi tutto occorre caricare il file immagine .tif in un qualsiasi programma di grafica e salvarlo in formato .jpg con lo stesso nome.
Poi occorre modificare con un editor di testo il file .tfw cancellando il numero 1 nella coordinata X (in pratica si sottrae alla coordinata il valore 1000000, in caso di fuso Est bisogna sottrarre 2020000):

0.63508119719307
0.00000000000000
0.00000000000000
-0.63508119719307
667638.02859124980000
4846354.74102050530000

A questo punto si caricano in Oruxmapsdesktop i 2 file calibrazione .tfw ed immagine .jpg, il programma darà errore per mancanza di Datum e Proiezione, si seleziona Rome 40: Italy (Sardinia) ed UTM fuso 32 e si converte la mappa in formato Orux



La mappa che ho prodotto funziona benissimo su Locus (non ho Orux) ed è calibrata perfettamente.

francesco
 
Ultima modifica:
Sei un grande davvero!

sembra essere andato tutto ok, anche Oruxmaps mi ha aperto il file convertito

Solo una cosa, questo era il mio file .tfw originale :

0.84698899999997
0.00000000000000
0.00000000000000
-0.84698899999997
1707772.11264354200000
4853022.93615850710000

Seguendo le tue indicazioni ho messo 0707772.11264354200000 giusto?
 


Alto Basso